CUPS < 2.0.1 SSLv3 Legacy Encryption Vulnerability (POODLE)

This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.


Synopsis :

The remote printer service is potentially affected by an information
disclosure vulnerability.

Description :

According to its banner, the CUPS printer service installed on the
remote host is a version prior to 2.0.1. It is, therefore, potentially
affected by a man-in-the-middle (MitM) information disclosure
vulnerability known as POODLE. The vulnerability is due to the way SSL
3.0 handles padding bytes when decrypting messages encrypted using
block ciphers in cipher block chaining (CBC) mode. MitM attackers can
decrypt a selected byte of a cipher text in as few as 256 tries if
they are able to force a victim application to repeatedly send the
same data over newly created SSL 3.0 connections.

Note that Nessus has not tested for this issue but has instead relied
only on the application's self-reported version number.

See also :

https://cups.org/blog.php?L734
https://cups.org/str.php?L4476
https://www.imperialviolet.org/2014/10/14/poodle.html
https://www.openssl.org/~bodo/ssl-poodle.pdf
https://tools.ietf.org/html/draft-ietf-tls-downgrade-scsv-00

Solution :

Either upgrade to CUPS version 2.0.1 or later, or apply the vendor
patch.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 3.1
(CVSS2#E:U/RL:TF/RC:UR)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 79580 ()

Bugtraq ID: 70574

CVE ID: CVE-2014-3566

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now