Adobe AIR for Mac <= 15.0.0.293 Multiple Vulnerabilities (APSB14-24)

This script is Copyright (C) 2014-2017 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host contains a version of Adobe AIR that is
affected by multiple vulnerabilities.

Description :

According to its version, the installation of Adobe AIR installed on
the remote Mac OS X host is equal or prior to 15.0.0.293. It is,
therefore, affected by the following vulnerabilities :

- Multiple memory corruption vulnerabilities allow an
attacker to execute arbitrary code. (CVE-2014-0576,
CVE-2014-0581, CVE-2014-8440, CVE-2014-8441)

- Multiple use-after-free vulnerabilities could result in
arbitrary code execution. (CVE-2014-0573, CVE-2014-0588,
CVE-2014-8438, CVE-2014-0574)

- Multiple type confusion vulnerabilities could result in
arbitrary code execution. (CVE-2014-0577, CVE-2014-0584,
CVE-2014-0585, CVE-2014-0586, CVE-2014-0590)

- Multiple heap-based buffer overflow vulnerabilities can
be exploited to execute arbitrary code or elevate
privileges. (CVE-2014-0583, CVE-2014-0582,
CVE-2014-0589)

- A permission issue that allows a remote attacker to gain
elevated privileges. (CVE-2014-8442)

- An information disclosure vulnerability can be exploited
to disclose secret session tokens. (CVE-2014-8437)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb14-24.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe AIR 15.0.0.356 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true