Mac OS X : OS X Server < 4.0 Multiple Vulnerabilities (POODLE)

This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.


Synopsis :

The remote host is missing a security update for OS X Server.

Description :

The remote Mac OS X host has a version of OS X Server installed that
is prior to version 4.0. It is, therefore, affected by the following
vulnerabilities :

- There are multiple vulnerabilities within the included
BIND, the most serious of which can lead to a denial of
service. (CVE-2013-3919, CVE-2013-4854, CVE-2014-0591)

- There are multiple vulnerabilities within the included
LibYAML for the Profile Manager and ServerRuby, the most
serious of which can lead to arbitrary code execution.
(CVE-2013-4164, CVE-2013-6393)

- There are multiple vulnerabilities within the included
PostgreSQL, the most serious of which can lead to
arbitrary code execution. (CVE-2014-0060, CVE-2014-0061,
CVE-2014-0062, CVE-2014-0063, CVE-2014-0064,
CVE-2014-0065, CVE-2014-0066)

- An error exists related to the way SSL 3.0 handles
padding bytes when decrypting messages encrypted using
block ciphers in cipher block chaining (CBC) mode. A
man-in-the-middle attacker can decrypt a selected byte
of a cipher text in as few as 256 tries if they are able
to force a victim application to repeatedly send the
same data over newly created SSL 3.0 connections. This
is also known as the 'POODLE' issue. (CVE-2014-3566)

- A cross-site scripting flaw exists in the Xcode Server
due to not properly validating input before returning it
to the user. This can allow a remote attacker, using a
specially crafted request, to execute code within the
browser / server trust relationship. (CVE-2014-4406)

- A SQL injection flaw exists in the Wiki Server due to
not properly sanitizing user input before using it in
SQL queries. This can allow a remote attacker, using a
specially crafted request, to inject or manipulate SQL
queries, thus allowing the manipulation or disclosure
of arbitrary data. (CVE-2014-4424)

- A restriction bypass flaw exists in the Mail Server due
to SCAL changes being cached and not enforced until the
service had restarted. This can allow an authenticated
remote attacker to bypass those restrictions.
(CVE-2014-4446)

- A password disclosure flaw exists in the Profile Manager
due to passwords being potentially saved to a file when
editing or setting up a profile. This can allow a local
attacker to gain access to password information.
(CVE-2014-4447)

See also :

http://support.apple.com/kb/HT6536
http://www.securityfocus.com/archive/1/533722/30/0/threaded
https://www.imperialviolet.org/2014/10/14/poodle.html
https://www.openssl.org/~bodo/ssl-poodle.pdf
https://tools.ietf.org/html/draft-ietf-tls-downgrade-scsv-00

Solution :

Upgrade to Mac OS X Server version 4.0 or later.

Note that OS X Server 4.0 is available only for OS X 10.10 or later.

Risk factor :

High / CVSS Base Score : 7.8
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C)
CVSS Temporal Score : 6.8
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true