This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.
The remote service is affected by multiple vulnerabilities.
According to its banner, the remote web server uses a version of
OpenSSL 1.0.1 prior to 1.0.1j. The OpenSSL library is, therefore,
affected by the following vulnerabilities :
- An error exists related to DTLS SRTP extension handling
and specially crafted handshake messages that can allow
denial of service attacks via memory leaks.
- An error exists related to the way SSL 3.0 handles
padding bytes when decrypting messages encrypted using
block ciphers in cipher block chaining (CBC) mode. A
man-in-the-middle attacker can decrypt a selected byte
of a cipher text in as few as 256 tries if they are able
to force a victim application to repeatedly send the
same data over newly created SSL 3.0 connections. This
is also known as the 'POODLE' issue. (CVE-2014-3566)
- An error exists related to session ticket handling that
can allow denial of service attacks via memory leaks.
- An error exists related to the build configuration
process and the 'no-ssl3' build option that allows
servers and clients to process insecure SSL 3.0
handshake messages. (CVE-2014-3568)
See also :
Upgrade to OpenSSL 1.0.1j or later.
Risk factor :
Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 4.3
Public Exploit Available : false