OpenSSL 0.9.8 < 0.9.8zc Multiple Vulnerabilities (POODLE)

This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.

Synopsis :

The remote service is affected by multiple vulnerabilities.

Description :

According to its banner, the remote web server uses a version of
OpenSSL 0.9.8 prior to 0.9.8zc. The OpenSSL library is, therefore,
affected by the following vulnerabilities :

- An error exists related to the way SSL 3.0 handles
padding bytes when decrypting messages encrypted using
block ciphers in cipher block chaining (CBC) mode. A
man-in-the-middle attacker can decrypt a selected byte
of a cipher text in as few as 256 tries if they are able
to force a victim application to repeatedly send the
same data over newly created SSL 3.0 connections. This
is also known as the 'POODLE' issue. (CVE-2014-3566)

- An error exists related to session ticket handling that
can allow denial of service attacks via memory leaks.

- An error exists related to the build configuration
process and the 'no-ssl3' build option that allows
servers and clients to process insecure SSL 3.0
handshake messages. (CVE-2014-3568)

See also :

Solution :

Upgrade to OpenSSL 0.9.8zc or later.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.7
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 78552 ()

Bugtraq ID: 70574

CVE ID: CVE-2014-3566

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now