Adobe AIR <= AIR 15.0.0.249 Multiple Vulnerabilities (APSB14-22)

This script is Copyright (C) 2014-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a version of Adobe AIR that is
affected by multiple vulnerabilities.

Description :

According to its version, the installation of Adobe AIR on the remote
Windows host is equal or prior to 15.0.0.249. It is, therefore,
affected by the following vulnerabilities :

- Multiple memory corruption issues due to improperly
sanitized user-supplied input allow arbitrary code
execution. (CVE-2014-0564, CVE-2014-0558)

- An integer overflow issue due to improperly sanitized
user-supplied input that allows arbitrary code
execution. (CVE-2014-0569)

- An arbitrary code execution vulnerability due to the
handling of a dereferenced memory pointer.
(CVE-2014-8439)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb14-22.html

Solution :

Upgrade to Adobe AIR 15.0.0.293 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 78440 ()

Bugtraq ID: 70437
70441
70442
71289

CVE ID: CVE-2014-0558
CVE-2014-0564
CVE-2014-0569
CVE-2014-8439

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now