ESXi 5.5 < Build 1980513 glibc Library Multiple Vulnerabilities (remote check)

This script is (C) 2014-2016 Tenable Network Security, Inc.


Synopsis :

The remote VMware ESXi 5.5 host is affected by multiple
vulnerabilities.

Description :

The remote VMware ESXi host is version 5.5 prior to build 1980513. It
is, therefore, affected by the following vulnerabilities in the glibc
library :

- A buffer overflow flaw exists in the 'extend_buffers'
function of the 'posix/regexec.c' file, due to not
properly validating user input. Using a specially
crafted expression, a remote attacker can cause a
denial of service. (CVE-2013-0242)

- A buffer overflow flaw exists in the 'getaddrinfo'
function of the '/sysdeps/posix/getaddrinfo.c' file,
due to not properly validating user input. A remote
attacker can cause a denial of service by triggering
a large number of domain conversions. (CVE-2013-1914)

See also :

http://lists.vmware.com/pipermail/security-announce/2014/000260.html

Solution :

Apply patch ESXi550-201409101-SG for ESXi 5.5.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 78108 ()

Bugtraq ID: 57638
58839

CVE ID: CVE-2013-0242
CVE-2013-1914

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now