WinSCP 5.x < 5.5.5 Multiple Vulnerabilities

This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has an application installed that is affected
by multiple vulnerabilities.

Description :

The WinSCP program installed on the remote host is version 4.3.8,
4.3.9, 4.4.0, or 5.x prior to 5.5.5. It therefore contains a bundled
version of OpenSSL prior to 1.0.1i which is affected by the following
vulnerabilities :

- A memory double-free error exists related to handling
DTLS packets that allows denial of service attacks.
(CVE-2014-3505)

- An unspecified error exists related to handling DTLS
handshake messages that allows denial of service attacks
due to large amounts of memory being consumed.
(CVE-2014-3506)

- A memory leak error exists related to handling
specially crafted DTLS packets that allows denial of
service attacks. (CVE-2014-3507)

- An error exists related to 'OBJ_obj2txt' and the pretty
printing 'X509_name_*' functions which leak stack data,
resulting in an information disclosure. (CVE-2014-3508)

- An error exists related to 'ec point format extension'
handling and multithreaded clients that allows freed
memory to be overwritten during a resumed session.
(CVE-2014-3509)

- A NULL pointer dereference error exists related to
handling anonymous ECDH cipher suites and crafted
handshake messages that allow denial of service attacks
against clients. (CVE-2014-3510)

- An error exists related to handling fragmented
'ClientHello' messages that allows a man-in-the-middle
attacker to force usage of TLS 1.0 regardless of higher
protocol levels being supported by both the server and
the client. (CVE-2014-3511)

- A buffer overflow error exists related to handling
Secure Remote Password protocol (SRP) parameters having
unspecified impact. (CVE-2014-3512)

- A NULL pointer dereference error exists related to
handling Secure Remote Password protocol (SRP) that
allows a malicious server to crash a client, resulting
in a denial of service. (CVE-2014-5139)

See also :

http://winscp.net/eng/docs/history#5.5.5
https://www.openssl.org/news/openssl-1.0.1-notes.html
https://www.openssl.org/news/secadv/20140806.txt
https://www.openssl.org/news/vulnerabilities.html

Solution :

Upgrade to WinSCP version 5.5.5 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now