VMware Security Updates for vCenter Server (VMSA-2014-0008)

This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.


Synopsis :

The remote host has a virtualization management application installed
that is affected by multiple security vulnerabilities.

Description :

The VMware vCenter Server installed on the remote host is version 5.0
prior to Update 3c, 5.1 prior to Update 3, or 5.5 prior to Update 2.
It is, therefore, affected by multiple vulnerabilities in third party
libraries :

- The bundled version of Apache Struts contains a code
execution flaw. Note that 5.0 Update 3c only addresses
this vulnerability. (CVE-2014-0114)

- The bundled tc-server / Apache Tomcat contains multiple
vulnerabilities. (CVE-2013-4590, CVE-2013-4322, and
CVE-2014-0050)

- The bundled version of Oracle JRE is prior to 1.7.0_55
and thus is affected by multiple vulnerabilities. Note
that this only affects version 5.5 of vCenter.

See also :

http://www.vmware.com/security/advisories/VMSA-2014-0008.html
http://lists.vmware.com/pipermail/security-announce/2014/000280.html

Solution :

Upgrade to VMware vCenter Server 5.5u2 (5.5.0 build-2001466) / 5.1u3
(5.1.0 build-2306353) / 5.0u3c (5.0.0 build-2210222) or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 9.0
(CVSS2#E:POC/RL:U/RC:ND)
Public Exploit Available : true