Flash Player <= 14.0.0.179 Multiple Vulnerabilities (APSB14-21)

This script is Copyright (C) 2014-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a browser plugin that is affected by
multiple vulnerabilities.

Description :

According to its version, the installation of Flash Player installed
on the remote Windows host is equal or prior to 14.0.0.179. It is,
therefore, affected by the following vulnerabilities :

- Unspecified memory corruption issues exist that allow
arbitrary code execution. (CVE-2014-0547, CVE-2014-0549,
CVE-2014-0550, CVE-2014-0551, CVE-2014-0552,
CVE-2014-0555)

- An unspecified error exists that allows cross-origin
policy violations. (CVE-2014-0548)

- A use-after-free error exists that allows arbitrary
code execution. (CVE-2014-0553)

- An unspecified error exists that allows an unspecified
security bypass. (CVE-2014-0554)

- Unspecified errors exist that allow memory leaks leading
to easier defeat of memory address randomization.
(CVE-2014-0557)

- Heap-based buffer overflow errors exist that allow
arbitrary code execution. (CVE-2014-0556, CVE-2014-0559)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb14-21.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe Flash Player version 15.0.0.152 or later.

Alternatively, Adobe has made version 13.0.0.244 available for those
installations that cannot be upgraded to 15.x.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now