openSUSE Security Update : gpgme (openSUSE-SU-2014:1039-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This gpgme update to version 1.4.4 fixes the following security and
non i security issues :

- Fixed possible overflow in gpgsm and uiserver engines.
(CVE-2014-3564, bnc#890123)

- Fixed possibled segv in gpgme_op_card_edit.

- Fixed minor memleaks and possible zombie processes.

- Fixed prototype inconsistencies and void pointer
arithmetic.

See also :

http://lists.opensuse.org/opensuse-updates/2014-08/msg00026.html
https://bugzilla.novell.com/show_bug.cgi?id=890123

Solution :

Update the affected gpgme packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 77289 ()

Bugtraq ID:

CVE ID: CVE-2014-3564

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now