Samba 4.x < 4.0.21 / 4.1.11 nmbd Remote Code Execution

This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.


Synopsis :

The remote Samba server is affected by a remote code execution
vulnerability.

Description :

According to its banner, the version of Samba on the remote host is
4.x prior to 4.0.21 / 4.1.11. It is, therefore, affected by a flaw in
the NetBIOS name services daemon (nmbd). This flaw may allow an
attacker to execute arbitrary code as the superuser.

Note that Nessus has not tested for this issue but has instead relied
only on the application's self-reported version number.

See also :

https://www.samba.org/samba/security/CVE-2014-3560.html
http://www.nessus.org/u?54321287

Solution :

Install the patch referenced in the project's advisory or upgrade to
4.0.21 / 4.1.11 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 76973 ()

Bugtraq ID: 69021

CVE ID: CVE-2014-3560

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now