openSUSE Security Update : ruby (openSUSE-SU-2011:0556-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

A memory corruption in the BigDecimal class potentially allowed
attackers to execute arbitrary code (CVE-2011-0188).

Affects 64bit platforms only.

See also :

http://lists.opensuse.org/opensuse-updates/2011-05/msg00059.html
https://bugzilla.novell.com/show_bug.cgi?id=682287

Solution :

Update the affected ruby packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 76014 ()

Bugtraq ID:

CVE ID: CVE-2011-0188

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now