openSUSE Security Update : opie (openSUSE-SU-2011:0848-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update fixes off-by-one errors in opiesu (CVE-2011-2489) and
missing setuid() return value checks in opielogin (CVE-2011-2490).

This update also removes the setuid bit from opiesu program. If you
rely on the setuid bit on opiesu, add the following line to
/etc/permissions.local :

/usr/bin/opiesu root:root 4755

See also :

http://lists.opensuse.org/opensuse-updates/2011-07/msg00039.html
https://bugzilla.novell.com/show_bug.cgi?id=698772

Solution :

Update the affected opie packages.

Risk factor :

High / CVSS Base Score : 7.2
(CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C)

Family: SuSE Local Security Checks

Nessus Plugin ID: 75988 ()

Bugtraq ID:

CVE ID: CVE-2011-2489
CVE-2011-2490

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now