openSUSE Security Update : postgresql (openSUSE-SU-2011:0254-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

A buffer overflow in the intarray module potentially allowed attackers
to execute arbitrary code as the user running postgresql
(CVE-2010-4015:CVSS v2 Base Score: 4.9). Additionally a possible log
forging problem was fixed too. (CVE-2010-4014)

See also :

http://lists.opensuse.org/opensuse-updates/2011-03/msg00035.html
https://bugzilla.novell.com/show_bug.cgi?id=660478

Solution :

Update the affected postgresql packages.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 75713 ()

Bugtraq ID:

CVE ID: CVE-2010-4014
CVE-2010-4015

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now