openSUSE Security Update : MozillaFirefox (openSUSE-SU-2011:1242-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

MozillaFirefox has been updated to version 3.6.24 to fix the following
security issues :

- MFSA 2011-46/CVE-2011-3647 (bmo#680880) loadSubScript
unwraps XPCNativeWrapper scope parameter

- MFSA 2011-47/CVE-2011-3648 (bmo#690225) Potential XSS
against sites using Shift-JIS

- MFSA 2011-49/CVE-2011-3650 (bmo#674776) Memory
corruption while profiling using Firebug

See also :

http://lists.opensuse.org/opensuse-updates/2011-11/msg00014.html
https://bugzilla.novell.com/show_bug.cgi?id=728520

Solution :

Update the affected MozillaFirefox packages.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)

Family: SuSE Local Security Checks

Nessus Plugin ID: 75657 ()

Bugtraq ID:

CVE ID: CVE-2011-3647
CVE-2011-3648
CVE-2011-3650

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now