openSUSE Security Update : libmysqlclient-devel (openSUSE-SU-2011:1250-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This mysql update fixes the following security issues

- CVE-2010-3833: CVSS v2 Base Score: 4.0 (moderate)
(AV:N/AC:L/Au:S/C:N/I:N/A:P): Resource Management Errors
(CWE-399)

- CVE-2010-3834: CVSS v2 Base Score: 4.0 (moderate)
(AV:N/AC:L/Au:S/C:N/I:N/A:P): Insufficient Information
(CWE-noinfo)

- CVE-2010-3835: CVSS v2 Base Score: 4.0 (moderate)
(AV:N/AC:L/Au:S/C:N/I:N/A:P): Numeric Errors (CWE-189)

- CVE-2010-3836: CVSS v2 Base Score: 4.0 (moderate)
(AV:N/AC:L/Au:S/C:N/I:N/A:P): Resource Management Errors
(CWE-399)

- CVE-2010-3837: CVSS v2 Base Score: 4.0 (moderate)
(AV:N/AC:L/Au:S/C:N/I:N/A:P): Resource Management Errors
(CWE-399)

- CVE-2010-3838: CVSS v2 Base Score: 4.0 (moderate)
(AV:N/AC:L/Au:S/C:N/I:N/A:P): Other (CWE-Other)

- CVE-2010-3839: CVSS v2 Base Score: 4.0 (moderate)
(AV:N/AC:L/Au:S/C:N/I:N/A:P): Design Error
(CWE-DesignError)

- CVE-2010-3840: CVSS v2 Base Score: 4.0 (moderate)
(AV:N/AC:L/Au:S/C:N/I:N/A:P): Other (CWE-Other)

See also :

http://lists.opensuse.org/opensuse-updates/2011-11/msg00018.html
https://bugzilla.novell.com/show_bug.cgi?id=644864

Solution :

Update the affected libmysqlclient-devel packages.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 75589 ()

Bugtraq ID:

CVE ID: CVE-2010-3833
CVE-2010-3834
CVE-2010-3835
CVE-2010-3836
CVE-2010-3837
CVE-2010-3838
CVE-2010-3839
CVE-2010-3840

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now