openSUSE Security Update : gnutls (openSUSE-SU-2014:0763-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

gnutls was patched to fix two security vulnerabilities that could be
used to disrupt service or potentially allow remote code execution.

- Memory corruption during connect (CVE-2014-3466)

- NULL pointer dereference in gnutls_x509_dn_oid_name
(CVE-2014-3465)

See also :

http://lists.opensuse.org/opensuse-updates/2014-06/msg00010.html
https://bugzilla.novell.com/show_bug.cgi?id=880730
https://bugzilla.novell.com/show_bug.cgi?id=880733

Solution :

Update the affected gnutls packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 75384 ()

Bugtraq ID:

CVE ID: CVE-2014-3465
CVE-2014-3466

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now