openSUSE Security Update : percona-toolkit / xtrabackup (openSUSE-SU-2014:0333-1)

This script is Copyright (C) 2014-2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

percona-toolkit and xtrabackup were updated :

- disable automatic version check for all tools
[bnc#864194] Prevents transmission of version
information to an external host in the default
configuration. CVE-2014-2029 Can be used by owner of a
Percona Server (or an attacker who can control this
destination for the client) to collect arbitrary MySQL
configuration parameters and execute commands (with -v).
Now the version check needs to be requested via command
line or global/tool specific/user configuration.
(--version-check)

- added /etc/percona-toolkit/percona-toolkit.conf
configuration directory and template configuration file

See also :

http://lists.opensuse.org/opensuse-updates/2014-03/msg00010.html
https://bugzilla.novell.com/show_bug.cgi?id=864194

Solution :

Update the affected percona-toolkit / xtrabackup packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.8
(CVSS2#E:ND/RL:U/RC:ND)
Public Exploit Available : false

Family: SuSE Local Security Checks

Nessus Plugin ID: 75277 ()

Bugtraq ID: 65621

CVE ID: CVE-2014-2029

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now