openSUSE Security Update : xen (openSUSE-SU-2013:1876-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

Xen was updated to 4.3.1 and also to fix various security issues and
bugs :

- bnc#851749 - Xen service file does not call xend
properly xend.service

- Add missing requires to pciutils package for xend-tools

- bnc#851386 - xen: XSA-78: Insufficient TLB flushing in
VT-d (iommu) code

- Make -devel package depend on libuuid-devel, since
libxl.h includes uuid.h

- bnc#849667 - CVE-2013-4553: xen: XSA-74: Lock order
reversal between page_alloc_lock and mm_rwlock

- bnc#849665 - CVE-2013-4551: xen: XSA-75: Host crash due
to guest VMX instruction execution

- bnc#849668 - CVE-2013-4554: xen: XSA-76: Hypercalls
exposed to privilege rings 1 and 2 of HVM guests

- bnc#848657 - xen: CVE-2013-4494: XSA-73: Lock order
reversal between page allocation and grant table locks

- Update to Xen 4.3.1

- bnc#845520 - CVE-2013-4416: xen: ocaml xenstored
mishandles oversized message replies

See also :

http://lists.opensuse.org/opensuse-updates/2013-12/msg00059.html
https://bugzilla.novell.com/show_bug.cgi?id=845520
https://bugzilla.novell.com/show_bug.cgi?id=848657
https://bugzilla.novell.com/show_bug.cgi?id=849665
https://bugzilla.novell.com/show_bug.cgi?id=849667
https://bugzilla.novell.com/show_bug.cgi?id=849668
https://bugzilla.novell.com/show_bug.cgi?id=851386
https://bugzilla.novell.com/show_bug.cgi?id=851749

Solution :

Update the affected xen packages.

Risk factor :

Medium / CVSS Base Score : 5.7
(CVSS2#AV:A/AC:M/Au:N/C:N/I:N/A:C)

Family: SuSE Local Security Checks

Nessus Plugin ID: 75232 ()

Bugtraq ID:

CVE ID: CVE-2013-4416
CVE-2013-4494
CVE-2013-4551
CVE-2013-4553
CVE-2013-4554

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now