openSUSE Security Update : ruby19 (openSUSE-SU-2013:1611-1)

This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

ruby19 was updated to fix the following security issues :

- fix CVE-2013-2065: Object taint bypassing in DL and
Fiddle (bnc#843686) The file CVE-2013-2065.patch
contains the patch

- fix CVE-2013-4287 CVE-2013-4363: ruby19: Algorithmic
complexity vulnerability (bnc#837457) The file
CVE-2013-4287-4363.patch contains the patch

See also :

http://lists.opensuse.org/opensuse-updates/2013-10/msg00057.html
https://bugzilla.novell.com/show_bug.cgi?id=837457
https://bugzilla.novell.com/show_bug.cgi?id=843686

Solution :

Update the affected ruby19 packages.

Risk factor :

Medium / CVSS Base Score : 6.4
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N)
CVSS Temporal Score : 4.7
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: SuSE Local Security Checks

Nessus Plugin ID: 75178 ()

Bugtraq ID: 59881
62281
62442

CVE ID: CVE-2013-2065
CVE-2013-4287
CVE-2013-4363

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now