openSUSE Security Update : libdmx (openSUSE-SU-2013:1029-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update of libdmx fixes several integer overflow issues.

-
U_0001-integer-overflow-in-DMXGetScreenAttributes-CVE-20
13-.patch,
U_0002-integer-overflow-in-DMXGetWindowAttributes-CVE-20
13-.patch,
U_0003-integer-overflow-in-DMXGetInputAttributes-CVE-201
3-1.patch,

- integer overflow in DMXGetScreenAttributes(),
DMXGetWindowAttributes(), DMXGetInputAttributes()
[CVE-2013-1992] (bnc#821663, bnc#815451)

See also :

http://lists.opensuse.org/opensuse-updates/2013-06/msg00157.html
https://bugzilla.novell.com/show_bug.cgi?id=815451
https://bugzilla.novell.com/show_bug.cgi?id=821663

Solution :

Update the affected libdmx packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.9
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: SuSE Local Security Checks

Nessus Plugin ID: 75046 ()

Bugtraq ID: 60142

CVE ID: CVE-2013-1992

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now