openSUSE Security Update : libXvMC (openSUSE-SU-2013:1025-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update of libXvMC fixes several integer overflow issues.

-
U_0001-integer-overflow-in-XvMCListSurfaceTypes-CVE-2013
-19.patch,
U_0002-integer-overflow-in-XvMCListSubpictureTypes-CVE-2
013.patch

- integer overflow in XvMCListSurfaceTypes(),
XvMCListSubpictureTypes() [CVE-2013-1990] (bnc#821663,
bnc#815451)

-
U_0001-Multiple-unvalidated-assumptions-in-XvMCGetDRInfo
-CV.patch

- Multiple unvalidated assumptions in XvMCGetDRInfo()
[CVE-2013-1999] (bnc#821663, bnc#815451)

See also :

http://lists.opensuse.org/opensuse-updates/2013-06/msg00153.html
https://bugzilla.novell.com/show_bug.cgi?id=815451
https://bugzilla.novell.com/show_bug.cgi?id=821663

Solution :

Update the affected libXvMC packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.9
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: SuSE Local Security Checks

Nessus Plugin ID: 75044 ()

Bugtraq ID: 60136
60144

CVE ID: CVE-2013-1990
CVE-2013-1999

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now