openSUSE Security Update : mcrypt (openSUSE-SU-2012:1440-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

Some potential mcrypt buffer overflows in the commandline tool were
fixed, which could lead to early aborts of mcrypt. Due to
FORTIFY_SOURCE catching such cases, it would have only aborted mcrypt
with a buffer overflow backtrace.

See also :

http://lists.opensuse.org/opensuse-updates/2012-11/msg00003.html
https://bugzilla.novell.com/show_bug.cgi?id=786100

Solution :

Update the affected mcrypt packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 74803 ()

Bugtraq ID:

CVE ID: CVE-2012-4527

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now