openSUSE Security Update : rubygem-actionpack-2_3 / rubygem-activesupport-2_3 (openSUSE-SU-2012:1218-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

- added 3-0-escape_html-activesupport.patch: (bnc#775653)
Also encode single quote (CVE-2012-3464)

- added 3-0-strip_tags.patch: (bnc#775649) Do not mark
strip_tags result as html_safe CVE-2012-3465

See also :

http://lists.opensuse.org/opensuse-updates/2012-09/msg00083.html
https://bugzilla.novell.com/show_bug.cgi?id=775649
https://bugzilla.novell.com/show_bug.cgi?id=775653

Solution :

Update the affected rubygem-actionpack-2_3 / rubygem-activesupport-2_3 packages.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N)

Family: SuSE Local Security Checks

Nessus Plugin ID: 74762 ()

Bugtraq ID:

CVE ID: CVE-2012-3464
CVE-2012-3465

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now