openSUSE Security Update : php5 (openSUSE-SU-2012:0976-1)

This script is Copyright (C) 2014-2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

Three security issues were fixed in php5 :

CVE-2012-2688: php5: potential overflow in _php_stream_scandir
CVE-2012-3365: open_basedir bypass via SQLite extension Also a out of
band read sql denial of service was fixed (bnc#769785)

See also :

http://lists.opensuse.org/opensuse-updates/2012-08/msg00019.html
https://bugzilla.novell.com/show_bug.cgi?id=769785
https://bugzilla.novell.com/show_bug.cgi?id=772580
https://bugzilla.novell.com/show_bug.cgi?id=772582

Solution :

Update the affected php5 packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: SuSE Local Security Checks

Nessus Plugin ID: 74709 ()

Bugtraq ID:

CVE ID: CVE-2012-2688
CVE-2012-3365

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now