openSUSE Security Update : bash (openSUSE-SU-2012:0898-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

Bash was fixed to avoid a possible buffer overflow when expanding the
/dev/fd prefix with e.g. the test builtin (bnc#770795) (CVE-2012-3410)

Due to _FORTIFY_SOURCE=2 enablement, the exploit will only abort the
shell.

See also :

http://lists.opensuse.org/opensuse-updates/2012-07/msg00038.html
https://bugzilla.novell.com/show_bug.cgi?id=770795

Solution :

Update the affected bash packages.

Risk factor :

Medium / CVSS Base Score : 4.6
(CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 74685 ()

Bugtraq ID:

CVE ID: CVE-2012-3410

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now