openSUSE Security Update : gypsy (openSUSE-SU-2012:0884-1)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

The following changes have been made :

- Add gypsy-CVE-2011-0523.patch: add config file to
restrict the files that can be read. Fix CVE-2011-0523
and bnc#666839.

- Add gypsy-CVE-2011-0524.patch: use snprintf() to avoid
buffer overflows. Fix CVE-2011-0524 and bnc#666839.

- Add gnome-common BuildRequires and call to
gnome-autogen.sh for gypsy-CVE-2011-0523.patch, since it
touches the build system.

See also :

http://lists.opensuse.org/opensuse-updates/2012-07/msg00034.html
https://bugzilla.novell.com/show_bug.cgi?id=666839

Solution :

Update the affected gypsy packages.

Risk factor :

Low / CVSS Base Score : 2.1
(CVSS2#AV:L/AC:L/Au:N/C:N/I:N/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 74681 ()

Bugtraq ID:

CVE ID: CVE-2011-0523
CVE-2011-0524

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now