openSUSE Security Update : flash-player (openSUSE-2011-4)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update provides flash-player 11.1.102.55, which files the
following critical security issues :

- This update resolves a memory corruption vulnerability
that could lead to code execution (CVE-2011-2445).

- This update resolves a heap corruption vulnerability
that could lead to code execution (CVE-2011-2450).

- This update resolves a memory corruption vulnerability
that could lead to code execution (CVE-2011-2451).

- This update resolves a memory corruption vulnerability
that could lead to code execution (CVE-2011-2452).

- This update resolves a memory corruption vulnerability
that could lead to code execution (CVE-2011-2453).

- This update resolves a memory corruption vulnerability
that could lead to code execution (CVE-2011-2454).

- This update resolves a memory corruption vulnerability
that could lead to code execution (CVE-2011-2455).

- This update resolves a buffer overflow vulnerability
that could lead to code execution (CVE-2011-2456).

- This update resolves a stack overflow vulnerability that
could lead to code execution (CVE-2011-2457).

- This update resolves a vulnerability that could lead to
a cross-domain policy bypass (Internet Explorer-only)
(CVE-2011-2458).

- This update resolves a memory corruption vulnerability
that could lead to code execution (CVE-2011-2459).

- This update resolves a memory corruption vulnerability
that could lead to code execution (CVE-2011-2460).

Solution :

Update the affected flash-player packages.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now