Mandriva Linux Security Advisory : libcap-ng (MDVSA-2014:117)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Mandriva Linux host is missing one or more security
updates.

Description :

Updated libcap-ng packages fix security vulnerability :

capng_lock() in libcap-ng before 0.7.4 sets securebits in an attempt
to prevent regaining capabilities using setuid-root programs. This
allows a user to run setuid programs, such as seunshare from
policycoreutils, as uid 0 but without capabilities, which is
potentially dangerous (CVE-2014-3215).

See also :

http://advisories.mageia.org/MGASA-2014-0251.html

Solution :

Update the affected packages.

Risk factor :

Medium / CVSS Base Score : 6.9
(CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.0
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Mandriva Local Security Checks

Nessus Plugin ID: 74450 ()

Bugtraq ID: 67341

CVE ID: CVE-2014-3215

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now