GLSA-201406-07 : Echoping: Buffer Overflow Vulnerabilities

This script is Copyright (C) 2014-2015 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201406-07
(Echoping: Buffer Overflow Vulnerabilities)

A boundary error exists within the “TLS_readline()” function, which
can be exploited to overflow a global buffer by sending an overly long
encrypted HTTP reply to Echoping. Also, a similar boundary error exists
within the “SSL_readline()” function, which can be exploited in the
same manner.

Impact :

A remote attacker could send a specially crafted HTTP reply, possibly
resulting in a Denial of Service condition.

Workaround :

There is no known workaround at this time.

See also :

https://security.gentoo.org/glsa/201406-07

Solution :

All Echoping users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose
'>=net-analyzer/echoping-6.0.2_p434'

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.9
(CVSS2#E:ND/RL:OF/RC:ND)
Public Exploit Available : false

Family: Gentoo Local Security Checks

Nessus Plugin ID: 74372 ()

Bugtraq ID: 45394

CVE ID: CVE-2010-5111

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now