GLSA-201406-06 : Mumble: Multiple vulnerabilities

This script is Copyright (C) 2014-2015 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201406-06
(Mumble: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Mumble:
A crafted length prefix value can trigger a heap-based buffer
overflow or NULL pointer dereference in the
opus_packet_get_samples_per_frame function (CVE-2014-0044)
A crafted packet can trigger an error in the opus_decode_float
function, leading to a heap-based buffer overflow (CVE-2014-0045)
A crafted SVG referencing local files can lead to resource exhaustion
or hangs (CVE-2014-3755)
Mumble does not properly escape HTML in some external strings before
displaying them (CVE-2014-3756)

Impact :

A remote attacker could possibly execute arbitrary code with the
privileges of the process or cause a Denial of Service condition.

Workaround :

There is no known workaround at this time.

See also :

https://security.gentoo.org/glsa/201406-06

Solution :

All Mumble users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=media-sound/mumble-1.2.6'

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.5
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Gentoo Local Security Checks

Nessus Plugin ID: 74371 ()

Bugtraq ID: 65369
65374
67400
67401

CVE ID: CVE-2014-0044
CVE-2014-0045
CVE-2014-3755
CVE-2014-3756

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now