Samba 4.x < 4.0.18 Multiple Vulnerabilities

This script is Copyright (C) 2014-2016 Tenable Network Security, Inc.


Synopsis :

The remote Samba server is potentially affected by multiple
vulnerabilities.

Description :

According to its banner, the version of Samba running on the remote
host is 4.x prior to 4.0.18 and is, therefore, potentially affected by
the following vulnerabilities :

- An error exists related to 'GET_SHADOW_COPY_DATA' or
'FSCTL_SRV_ENUMERATE_SNAPSHOTS' request handling and
'vfs objects' parameter configurations of 'shadow_copy'
or 'shadow_copy2' that could allow disclosure of
uninitialized memory contents. (CVE-2014-0178)

- An error exists related to handling the 'reply' flag
DNS packet headers that could allow denial of service
attacks. (CVE-2014-0239)

Note that Nessus has relied only on the self-reported version number
and has not actually tried to exploit these issues or determine if the
associated patch has been applied.

See also :

https://www.samba.org/samba/security/CVE-2014-0178.html
https://www.samba.org/samba/security/CVE-2014-0239.html
http://www.samba.org/samba/history/samba-4.0.18.html
http://www.nessus.org/u?da7865ef

Solution :

Either install the patch referenced in the project's advisory, or
upgrade to 4.0.18 or later.

Alternatively, refer to the vendor advisories and apply the suggested
workarounds.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 74242 ()

Bugtraq ID: 67686
67691

CVE ID: CVE-2014-0178
CVE-2014-0239

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now