Mandriva Linux Security Advisory : php (MDVSA-2014:087)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote Mandriva Linux host is missing one or more security
updates.

Description :

A vulnerability has been discovered and corrected in php :

PHP FPM in PHP versions before 5.4.28 and 5.5.12 uses a UNIX domain
socket with world-writable permissions by default, which allows any
local user to connect to it and execute PHP scripts as the apache user
(CVE-2014-0185).

The updated php packages have been upgraded to the 5.5.12 version
which is not vulnerable to this issue.

Additionally, the timezonedb packages has been upgraded to the latest
2014.3 version, the php-suhosin packages has been upgraded to the
latest 0.9.35 version which has better support for php-5.5 and the
PECL packages which requires so has been rebuilt for php-5.5.12.

Solution :

Update the affected packages.

Risk factor :

High / CVSS Base Score : 7.2
(CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Mandriva Local Security Checks

Nessus Plugin ID: 74029 ()

Bugtraq ID: 67118

CVE ID: CVE-2014-0185

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now