Apache Struts 2 CookieInterceptor Unspecified Security Bypass

This script is Copyright (C) 2014-2017 Tenable Network Security, Inc.


Synopsis :

The remote web server contains a web application that uses a Java
framework that is affected by a security bypass vulnerability.

Description :

The remote web application appears to use Struts 2, a Java based web
application framework. The version of Struts 2 in use is affected by
a security bypass vulnerability due to a flaw with CookieInterceptor.
A remote, unauthenticated attacker can exploit this issue to
manipulate the ClassLoader and modify a session state to bypass
security restrictions.

Note that this vulnerability can only be exploited when a wildcard
character is used to configure the 'cookiesName' value.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://struts.apache.org/docs/s2-022.html
https://cwiki.apache.org/confluence/display/WW/S2-022

Solution :

Upgrade to version 2.3.16.3 or later.

Risk factor :

Medium / CVSS Base Score : 5.8
(CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:P)
CVSS Temporal Score : 4.8
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 73944 ()

Bugtraq ID: 67218

CVE ID: CVE-2014-0116

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now