VMware vSphere Client Multiple Vulnerabilities (VMSA-2014-0003)

This script is Copyright (C) 2014 Tenable Network Security, Inc.


Synopsis :

The remote host has a virtualization client application installed that
is affected by multiple vulnerabilities.

Description :

The version of vSphere Client installed on the remote Windows host is
affected by the following vulnerabilities :

- An error exists related to the vSphere Client that
could allow an updated vSphere Client to be downloaded
from an untrusted source. (CVE-2014-1209)

- An error exists related to the vSphere Client and
server certificate validation that could allow an
attacker to spoof a vCenter server. Note that this
issue only affects vSphere Client versions 5.0 and 5.1.
(CVE-2014-1210)

See also :

http://www.vmware.com/security/advisories/VMSA-2014-0003.html

Solution :

Upgrade to vSphere Client 5.0 Update 3 / 5.1 Update 2 or later.

In the case of vSphere Client 4.x, refer to the vendor's advisory.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 73595 ()

Bugtraq ID: 66772
66773

CVE ID: CVE-2014-1209
CVE-2014-1210

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now