phpMyAdmin 3.x >= 3.3.1 / 4.x < 4.1.7 import.php XSS (PMASA-2014-1)

This script is Copyright (C) 2014-2015 Tenable Network Security, Inc.

Synopsis :

The remote web server hosts a PHP application that is affected by a
cross-site scripting vulnerability.

Description :

According to its self-identified version number, the phpMyAdmin install
hosted on the remote web server is 3.x later than 3.3.1 or 4.x prior to
4.1.7. It is, therefore, affected by a cross-site scripting
vulnerability because the 'import.php' script does not properly sanitize
the filenames of imported files.

See also :

Solution :

Either upgrade to phpMyAdmin 4.1.7 or later, or apply the patch from
the referenced link.

Risk factor :

Low / CVSS Base Score : 3.5
CVSS Temporal Score : 3.0
Public Exploit Available : true

Family: CGI abuses : XSS

Nessus Plugin ID: 72714 ()

Bugtraq ID: 65717

CVE ID: CVE-2014-1879

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now