XnView 2.x < 2.04 Multiple Buffer Overflow Vulnerabilities

This script is Copyright (C) 2013-2016 Tenable Network Security, Inc.

Synopsis :

The remote Windows host contains an application that is affected by
multiple buffer overflow vulnerabilities.

Description :

The version of XnView installed on the remote Windows host is 2.x,
earlier than 2.04. It is, therefore, reportedly affected by the
following overflow vulnerabilities:

- An unspecified error exists that could allow a buffer
overflow during 'PCT' file handling. (CVE-2013-2577)

- Unspecified errors exist that could allow heap-based
buffer overflows during 'FPX' and 'PSP' file handling.
(CVE-2013-3492, CVE-2013-3493)

See also :


Solution :

Upgrade to XnView version 2.04 or later.

Risk factor :

High / CVSS Base Score : 9.3
CVSS Temporal Score : 7.3
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 69137 ()

Bugtraq ID: 61397

CVE ID: CVE-2013-2577

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now