XnView 2.x < 2.04 Multiple Buffer Overflow Vulnerabilities

This script is Copyright (C) 2013-2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains an application that is affected by
multiple buffer overflow vulnerabilities.

Description :

The version of XnView installed on the remote Windows host is 2.x,
earlier than 2.04. It is, therefore, reportedly affected by the
following overflow vulnerabilities:

- An unspecified error exists that could allow a buffer
overflow during 'PCT' file handling. (CVE-2013-2577)

- Unspecified errors exist that could allow heap-based
buffer overflows during 'FPX' and 'PSP' file handling.
(CVE-2013-3492, CVE-2013-3493)

See also :

http://newsgroup.xnview.com/viewtopic.php?f=35&t=28400
http://seclists.org/bugtraq/2013/Jul/152

Solution :

Upgrade to XnView version 2.04 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 69137 ()

Bugtraq ID: 61397
61503
61505

CVE ID: CVE-2013-2577
CVE-2013-3492
CVE-2013-3493

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now