Adobe PageMaker 7.0.1 / 7.0.2 Multiple Vulnerabilities (APSA08-10)

This script is Copyright (C) 2013-2016 Tenable Network Security, Inc.


Synopsis :

The remote host has software installed that is affected by multiple
code execution vulnerabilities.

Description :

The remote host has a version of Adobe PageMaker installed that
contains a version of AldFs32.dll that is affected by multiple code
execution vulnerabilities :

- A heap-based buffer overflow exists that could allow
remote attackers to execute arbitrary code via malformed
.PMD files. (CVE-2007-6021)

- Multiple stack-based buffer overflow vulnerabilities
exist that could allow remote attackers to execute
arbitrary code via malformed .PMD files. (CVE-2007-5394,
CVE-2007-6432)

See also :

http://www.adobe.com/support/security/advisories/apsa08-10.html

Solution :

Install the version of AldFS32.dll linked in the advisory.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 69099 ()

Bugtraq ID: 31975
31999

CVE ID: CVE-2007-5394
CVE-2007-6021
CVE-2007-6432

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now