VLC < 2.0.7 Multiple Vulnerabilities

This script is Copyright (C) 2013-2015 Tenable Network Security, Inc.

Synopsis :

The remote Windows host contains a media player that is affected by
multiple vulnerabilities.

Description :

The version of VLC media player installed on the remote host is earlier
than 2.0.7 and is, therefore, affected by the following vulnerabilities:

- The web interface contains a flaw that does not validate
input passed via XML services resulting in a cross-site
scripting vulnerability.

- A flaw exists in the XML services of the web interface
that may allow a remote attacker to execute media player

- A flaw exists that could lead to a denial of service /
memory consumption when loading a malicious playlist.

See also :


Solution :

Upgrade to VLC version 2.0.7 or later.

Risk factor :

Medium / CVSS Base Score : 4.3
CVSS Temporal Score : 3.2
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 69015 ()

Bugtraq ID: 60705

CVE ID: CVE-2013-3564

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now