Apache Subversion < 1.6.23 / 1.7.x < 1.7.10 Multiple Remote DoS

This script is Copyright (C) 2013-2014 Tenable Network Security, Inc.


Synopsis :

The remote host has an application that is affected by multiple denial
of service vulnerabilities.

Description :

The installed version of Apache Subversion Server is prior to 1.6.23
or 1.7.x prior to 1.7.10. It is, therefore, affected by multiple
remote denial of service vulnerabilities :

- A flaw exists when handling specially crafted filenames
that could result in corruption of the FSFS repository.
A workaround exists to install a pre-commit hook that
will prevent unsanitized filenames from being committed
into the repository. (CVE-2013-1968)

- A flaw exists in svnserve server where improperly
handled aborted connection message are handled as
critical errors. (CVE-2013-2112)

See also :

http://subversion.apache.org/security/CVE-2013-1968-advisory.txt
http://subversion.apache.org/security/CVE-2013-2112-advisory.txt

Solution :

Upgrade to Apache Subversion Server 1.6.23 / 1.7.10 / 1.8.0 or later
or apply the vendor patches or workarounds.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.3
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 68930 ()

Bugtraq ID: 60264
60267

CVE ID: CVE-2013-1968
CVE-2013-2112

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now