Apache 2.0.x < 2.0.65 Multiple Vulnerabilities

This script is Copyright (C) 2013-2017 Tenable Network Security, Inc.

Synopsis :

The remote web server is affected by several vulnerabilities.

Description :

According to its banner, the version of Apache 2.0.x running on the
remote host is prior to 2.0.65. It is, therefore, affected by several
vulnerabilities :

- A flaw exists in the byte-range filter, making it
vulnerable to denial of service. (CVE-2011-3192)

- A flaw exists in 'mod_proxy' where it doesn't properly
interact with 'RewriteRule' and 'ProxyPassMatch'
in reverse proxy configurations. (CVE-2011-3368)

- A privilege escalation vulnerability exists relating to
a heap-based buffer overflow in 'ap_pregsub' function in
'mod_setenvif' module via .htaccess file.

- A local security bypass vulnerability exists within
scoreboard shared memory that may allow the child
process to cause the parent process to crash.

- A flaw exists within the status 400 code when no custom
ErrorDocument is specified that could disclose
'httpOnly' cookies. (CVE-2012-0053)

- A flaw exists in the 'RewriteLog' function where it
fails to sanitize escape sequences written to log files,
which could result in arbitrary command execution.

Note that the remote web server may not actually be affected by these
vulnerabilities. Nessus did not try to determine whether the affected
modules are in use nor did it test for the issues themselves.

See also :


Solution :

Upgrade to Apache version 2.0.65 or later. Alternatively, ensure that
the affected modules are not in use.

Risk factor :

High / CVSS Base Score : 7.8
CVSS Temporal Score : 6.1
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now