Winamp < 5.64 Multiple Vulnerabilities

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a multimedia application that is
affected by multiple vulnerabilities.

Description :

The remote host is running Winamp, a media player for Windows.

The version of Winamp installed on the remote host is earlier than 5.64
and is, therefore, reportedly affected by the following
vulnerabilities :

- A buffer overflow exists in the 'ml_local.dll' when
passed GUI search fields.

- A buffer overflow exists in the 'gen_jumpex.dll' when
handling Skins directory names.

- Invalid pointer dereference vulnerabilities exist in
the 'gen_ff.dll' library when loading the links.xml.

Successful exploitation can allow arbitrary code execution.

See also :

http://security.inshell.net/advisory/51
http://security.inshell.net/advisory/52
http://forums.winamp.com/showthread.php?t=364291
http://www.winamp.com/help/Version_History

Solution :

Upgrade to Winamp 5.64 (5.6.4.3418) or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 67207 ()

Bugtraq ID: 60883
60886

CVE ID: CVE-2013-4694
CVE-2013-4695

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now