Google SketchUp < 8.0.11752 MAC Pict Buffer Overflow

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

A 3-D modeling application on the remote Windows host is affected by a
buffer overflow vulnerability.

Description :

The version of Google SketchUp installed on the remote Windows host is
earlier than 8.0.11752. As such, it reportedly is affected by a buffer
overflow vulnerability.

An error exists related to the handling of embedded MAC Pict textures
that allows a stack-based buffer overflow, leading to application
crashes or arbitrary code execution.

See also :

http://www.nessus.org/u?32c70014
http://www.binamuse.com/advisories/BINA-20111201.txt

Solution :

Upgrade to Google SketchUp 8.0 Maintenance 2 (8.0.11752) or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 66925 ()

Bugtraq ID: 60250

CVE ID: CVE-2013-3662

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now