Apache Tomcat 7.0.x < 7.0.40 Multiple Vulnerabilities

This script is Copyright (C) 2013-2016 Tenable Network Security, Inc.

Synopsis :

The remote Apache Tomcat server is affected by multiple

Description :

According to its self-reported version number, the instance of Apache
Tomcat 7.0 listening on the remote host is prior to 7.0.40. It is,
therefore, affected by multiple vulnerabilities :

- An error exists related to 'AsyncListeners' that throw
'RuntimeExceptions' that allow elements of certain
requests to be disclosed in responses to other requests.

- It is possible to upload a malicious JSP to a Tomcat
server and subsequently trigger execution of that JSP.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :


Solution :

Update to Apache Tomcat version 7.0.40 or later.

Risk factor :

Low / CVSS Base Score : 2.6
CVSS Temporal Score : 2.3
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 66428 ()

Bugtraq ID: 59798

CVE ID: CVE-2013-2071

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now