VLC < 2.0.6 ASF Demuxer Buffer Overflow

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a media player that is affected by a
buffer overflow vulnerability.

Description :

The version of VLC media player installed on the remote host is earlier
than 2.0.6. It is, therefore, reportedly affected by a buffer overflow
vulnerability related to the ASF demuxer plugin.

See also :

http://www.videolan.org/security/sa1302.html
http://www.nessus.org/u?b8052708
http://trac.videolan.org/vlc/ticket/8024
http://www.videolan.org/vlc/releases/2.0.6.html

Solution :

Upgrade to VLC version 2.0.6 or later. Alternatively, remove the
affected plugin file from VLC's plugins directory.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 66216 ()

Bugtraq ID: 57333

CVE ID: CVE-2013-1954

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now