RealPlayer for Windows < 16.0.1.18 MP4 Heap-Based Buffer Overflow

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

A multimedia application on the remote Windows host is affected by a
buffer overflow vulnerability.

Description :

According to its build number, the installed version of RealPlayer on
the remote Windows host is earlier than 16.0.1.18. It is, therefore,
affected by a heap-based buffer overflow vulnerability related to
handling malformed MP4 files that could lead to arbitrary code
execution.

See also :

http://service.real.com/realplayer/security/03152013_player/en/

Solution :

Upgrade to RealPlayer 16.0.1.18 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 65630 ()

Bugtraq ID: 58539

CVE ID: CVE-2013-1750

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now