AIX 5.3 TL 9 : pcnfsd (IZ73874)

This script is Copyright (C) 2013 Tenable Network Security, Inc.


Synopsis :

The remote AIX host is missing a security patch.

Description :

'An integer overflow vulnerability was reported in the rpc.pcnfsd
service within the several systems. The rpc.pcnfsd daemon handles
requests from PC-NFS clients for authentication services on remote
machines. These services include authentication for mounting and for
print spooling. The vulnerability is triggered when parsing crafted
RPC requests. A remote attacker can leverage this vulnerability by
sending a crafted RPC message to the target host, to potentially
inject and execute arbitrary code.'.

See also :

http://www.nessus.org/u?59da8842
http://aix.software.ibm.com/aix/efixes/security/pcnfsd_advisory.asc

Solution :

Install the appropriate interim fix.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)

Family: AIX Local Security Checks

Nessus Plugin ID: 63818 ()

Bugtraq ID:

CVE ID: CVE-2010-1039

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now