Apache Tomcat 7.0.x < 7.0.30 Multiple Vulnerabilities

This script is Copyright (C) 2012-2016 Tenable Network Security, Inc.

Synopsis :

The remote Apache Tomcat server is affected by multiple

Description :

According to its self-reported version number, the instance of Apache
Tomcat 7.0 listening on the remote host is prior to 7.0.30. It is,
therefore, affected by the following vulnerabilities :

- An error related to chunked transfer encoding and
extensions allows limited denial of service attacks.

- An error exists related to FORM authentication that
allows security bypass if 'j_security_check' is appended
to the request. (CVE-2012-3546)

- Replay-countermeasure functionality in HTTP Digest
Access Authentication tracks cnonce values instead of
nonce values, which makes it easier for attackers to
bypass access restrictions by sniffing the network for
valid requests. (CVE-2012-5885)

- HTTP Digest Access Authentication implementation caches
information about the authenticated user, which allows
an attacker to bypass authentication via session ID.

- HTTP Digest Access Authentication implementation does
not properly check for stale nonce values with
enforcement of proper credentials, which allows an
attacker to bypass restrictions by sniffing requests.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :


Solution :

Upgrade to Apache Tomcat version 7.0.30 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
CVSS Temporal Score : 4.1
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 62988 ()

Bugtraq ID: 56403

CVE ID: CVE-2012-3544

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now