Firefox < 16.0.1 Multiple Vulnerabilities

This script is Copyright (C) 2012-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host contains a web browser that is affected by
multiple vulnerabilities.

Description :

The installed version of Firefox is earlier than 16.0.1 and is
therefore potentially affected by the following security issues :

- An unspecified error related to the WebSockets
implementation and the function
'mozilla::net::FailDelayManager::Lookup' can allow
application crashes and potentially, arbitrary code
execution. (CVE-2012-4191)

- An unspecified error exists that can allow attackers to
bypass the 'Same Origin Policy' and access the
'Location' object. (CVE-2012-4192)

- An error exists related to 'security wrappers' and the
function 'defaultValue()' that can allow cross-site
scripting attacks. (CVE-2012-4193)

See also :

http://www.nessus.org/u?8993e6b4
http://www.nessus.org/u?dc43f3c3
https://www.mozilla.org/en-US/security/advisories/mfsa2012-88/
https://www.mozilla.org/en-US/security/advisories/mfsa2012-89/

Solution :

Upgrade to Firefox 16.0.1 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.1
(CVSS2#E:ND/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 62589 ()

Bugtraq ID: 56153
56154
56155

CVE ID: CVE-2012-4191
CVE-2012-4192
CVE-2012-4193

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now